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Abstract: 
 
This report outlines a methodology accessible to instructors at Mt. Hood Community College (MHCC) for 
converting Microsoft PowerPoint lectures into Flash movies.  Flash movies are easily distributed with the 
web and/or CDs and DVDs, making them an exciting learning tool for technologically savvy instructors. 
 
Two separate sections detail possible routes for the conversion of PowerPoint presentations into Flash 
movies.  Section II outlines in detail a methodology open to everyone with access to both PowerPoint and 
Flash; presentations are converted into a slide show with common replay buttons.  Section III provides a list 
of the commercial software titles available on the internet that convert PowerPoint presentations to Flash 
movies automatically, and a brief review of each program is included. 
 
Examples of converted PowerPoint presentations have been created within the parameters of this project and 
shared with the community.  The procedures used to create the Flash movies are provided along with a 
treatise on alternative methods to deliver classroom lectures online. 
 
This document and all supplementary materials may be viewed on the World Wide Web:   
 http://www.gst-d2L.com/TLC 
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I.  Introduction to PowerPoint and Flash, or Why Would Anyone Wish to Convert a 
       PowerPoint Presentation into a Flash Movie 
 
As an educator and web designer, I found myself needing a medium to recreate my lecture experience on the 
internet.  I have taught a "traditional" chemistry course for many years, and I have also had the pleasure of 
teaching the same class in "hybrid" web-based fashion (meaning students have both online learning sessions 
as well as "face to face" portions.)  In the hybrid chemistry class, students participate in one four hour lab 
session each week, and the "traditional" lectures were replaced by "learning the lecture material on your 
own" with augmented online study materials, handouts, etc.  My goal being equanimity for all my students in 
all sections, I have tried to make the learning experience within my hybrid class as similar to my traditional 
class as much as possible. 
 
The major disadvantage of my hybrid class quickly revealed itself.  Students in the traditional class had 
constant motivation through my lectures which provided not only the intellectual kindling for their learning 
but also the emotional "pat on the back" needed by the non-motivated students.  My hybrid students had no 
such advantage, and students in the hybrid classes fell into two groups: those who successfully acquired the 
chemistry knowledge using their own means to learn the material and those who failed to motivate 
themselves to learn the required chemical concepts.  Those who did not master the concepts failed or 
withdrew from the class. 
 
As a Microsoft PowerPoint lecturer, I reasoned that there must be some method by which 
the PowerPoint slides could be transferred to the web to simulate the lecture experience 
obtained by my "traditional" lecture students.  If my hybrid students would avail 
themselves of the virtual lecture, they could obtain their motivation for learning and not 
succumb to academic and learning apathy (and thus fail.) 
 
My first attempt at delivering a virtual lecture was to let students download my PowerPoint files directly to 
their computer from the web.  Try this yourself by downloading a sample PowerPoint file here: 
 

http://gst-d2L.com/TLC/PP2FCT/TLC7PPTExample.ppt 
 
I quickly ran into problems with this approach.  Not everyone had PowerPoint (although a free PowerPoint 
viewer is available for both Macintosh and Windows), making viewing difficult.  The layout of the slides 
looked different due to font differences between Macintosh computers (which I use) and Windows PCs.  
Finally, some of the multimedia did not play correctly (the movies did not transfer with the PowerPoint file.)  
This approach proved too cumbersome and unwieldy to use in the classroom. 
 
In my second attempt, I used PowerPoint Outlines.  A PowerPoint outline is a text-only outline of your 
presentation saved in RTF (i.e. Microsoft Word) format that looks pretty much the same on all platforms.  
You can view an example of a PowerPoint Outline here: 
 

http://gst-d2L.com/TLC/PP2FCT/TLC7PPTExample.rtf 
 
Outlines worked ok, but the spirit of the presentation eluded this methodology.  Notes added to the original 
text boxes are included in the outline, but additional text boxes added later are omitted.  In addition, all 
animations, audio, graphics, video and color are excluded from the outline.  Outlines provide a skeleton 
overview of the content within the lecture, but they do not provide the pizzazz and individuality that make 
lectures entertaining. 
 



 

"PowerPoint to Flash Conversion Techniques" TLC Innovation Grant Page 3 by Michael Russell 

 
 
A third attempt at creating an online lecture utilized PowerPoint's "Make Movie" technique.  This process 
converts your PowerPoint lecture into a viewable movie that attempts to recreate the lecture experience.  You 
can view an example of a PowerPoint movie here: 
 

http://classes.mhcc.edu/web/ch221_mr/media/TLC7PPTExample.mov 
 
You will need QuickTime (http://www.apple.com/quicktime) to view this movie. 
 
The "Make Movie" protocol has the power to re-create the lecture experience, but its implementation almost 
always falls short of the desired goal.  Transitions are flawed (often too fast or too slow), the colors are 
translated incorrectly, and it never feels like a real lecture.  File sizes are quite large, making download times 
unacceptably large for slow internet connections.  In addition, if the visitor does not have the required 
software plug-in (QuickTime, in this case), then they cannot view the movie at all. 
 
A fourth approach that I investigated utilized the Tegrity system (http://www.tegrity.com/)  Available on the 
MHCC campus (contact Mitch Klink for more information), Tegrity allows the user to take a PowerPoint 
lecture, augment it with a video recording and Whiteboard-like technology, then save it as a web-viewable 
document.  Tegrity has great promise, but it offers no native Macintosh development software (it must be run 
on a Windows computer) and time to develop a class must be arranged with the Distance Learning 
community.  I find that my class development occurs at all hours of the day or night, seven days a week, and 
having to schedule a time to prepare a lecture hinders my creative process.  In addition, simply playing back 
the movies on many browsers has proven troublesome.  For these reasons I have chosen not to pursue 
Tegrity as a learning tool.  (However, I see great potential in another cross-platform Tegrity-like solution 
called Cast:Stream (http://www.caststream.com/), and if MHCC finds the resources to acquire a Cast:Stream 
system, I would be its most avid user!) 
 
A fifth attempt at creating an online lecture involved the use of the "Save as Web Page" feature.  PowerPoint 
will convert your presentation into a series of web (HTML) pages viewable on almost any web browser 
(Internet Explorer, Netscape, Firefox, Safari, etc.)  An example of a PowerPoint file saved as a series of web 
pages can be found here: 
 

http://gst-d2L.com/TLC/PP2FCT/TLC7PPTExample.htm 
 
The PowerPoint files saved as web pages proved to be a better option than the PowerPoint outline mentioned 
earlier, but it still had limitations.  Students could scan the PowerPoint slides using the outline feature of the 
web pages and scroll to the respective slide.  Also, students wishing simply an overview of important 
concepts from the lecture could quickly ascertain relevant material without having to scroll through endless 
series of notes.  However, the process of viewing a lecture using static (i.e. non-moving or minimally 
interactive) web pages was far too boring for all but the most determined of students.  In addition, 
multimedia playback hampered several student browsers, requiring a download and plug-in before the 
lecture material could be viewed.  In addition, the "feel" of the lecture through the web pages did not 
correspond with the "traditional" lecture. 
 
This being said, I still use the PowerPoint to web page conversion process in my classes.  Because students 
can quickly ascertain important lecture concepts, I find this a helpful learning tool for some students. 
 
A sixth approach that I tried used the power of Adobe Acrobat Professional to convert PowerPoint slides into 
PDF documents.  Each slide in the PowerPoint presentation can be converted to a separate PDF file in a PDF 
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document.  You can view an example of this approach here: 
 

http://gst-d2L.com/TLC/PP2FCT/TLC7PPTExample.pdf 
 
PDF documents from PowerPoint presentations experience the same drawback as the "Save as Web Page" 
feature outlined earlier: they are so boring to view!  Viewing a web page or a PDF file is equally somnolent, 
and all but the most dedicated students failed to make it through an entire lecture.  Also, the multimedia in 
PowerPoint rarely translated itself well into the Adobe PDF format.  Adobe claims that multimedia 
conversion gets better in each version, but I have not seen a sufficient level of multimedia adhesion upon 
changing formats.  The PDF format did not work well for virtual lecture creation. 
 
None of the approaches listed so far provide an adequate virtual lecture experience for online students.  What 
is needed is a graphics and multimedia savvy program that can take PowerPoint's rich media and preserve it 
in a web-accessible size and content that should not require additional downloadable software to experience.  
Hence, this is how I became acquainted with Macromedia Flash. 
 
 

Macromedia Flash as a Compliment to PowerPoint 
 
I had heard rumors about people converting PowerPoint lectures 
into Macromedia Flash lectures for years, but it took two "teaser" 
lectures by MHCC's Jeff Rouyer to crystallize my interest.  During 
fall quarter 2004 and spring quarter 2005 Jeff gave two 
"introductory" lectures to Distance Learning (DL) faculty who 
might be interested in converting their PowerPoint lectures into 
Flash presentations.  I attended both of Jeff's lectures, and 
regrettably the focus of both lectures blossomed into a general 
multimedia roundtable-like discussion (how do I make a movie, 
what is the difference between GIF and JPG, etc.)  My curiosity 
was piqued, but hardly satiated. 
 
Several introductory classes are available through MHCC for learning Flash, specifically: 
 

• CIS125FLA - Flash Level 1 (Introduction to Flash) 
• CIS125FLB - Flash Level 2 (Shape Tweening, Hints, etc.) 
• CIS125FLC - Flash Level 3 (Macromedia Extensions, etc.) 
• CIS125FLD - Flash Level 4 (ActionScript programming, etc.) 

 
I had taken these four classes previously in my desire to become web savvy, so I was somewhat familiar with 
Flash.  Macromedia Flash is touted as the "industry's most advanced authoring environment for creating 
interactive websites, digital experiences and mobile content" on the official Macromedia website, and this is 
a pretty decent explanation for the many capabilities of Flash.  Unlike other web graphics programs (like 
Fireworks, Photoshop or Illustrator), Flash incorporates tools for (primarily) two-dimensional animation.  
Objects can be layered and manipulated in time, providing for a wealth of creative opportunities to the Flash 
designer. 
 
Logic dictates that Flash would be an acceptable medium for converting PowerPoint presentations and 
preparing them for delivery on the web.  Flash is heavily multimedia based, and its inherent vector graphics 
(which require less memory than the traditional raster graphics) create smaller file sizes that download 

 
 



 

"PowerPoint to Flash Conversion Techniques" TLC Innovation Grant Page 5 by Michael Russell 

 
quicker on the internet.  This is important if your lectures are large or if you simply want to keep student 
attention directed at your presentation. 
 
Better yet, more than 98% of all internet browsers come pre-configured with the Flash plug-in (according to 
Macromedia), and the software is available on more than one platform (including Windows, Macintosh, 
Linux, Solaris, PDAs, and many others).  This means that students should not have to download any 
additional software to view a Flash presentation on their browser, and they can be using just about any 
internet accessible program on any platform and not experience viewing difficulties. 
 
Flash can incorporate almost any multimedia type, from audio (.mp3, .au,  .wav, etc.), graphics (.gif, .jpg, 
.png, etc.) and many types of video.  Playback of Flash movies is supported at almost any screen resolution, 
so people with small screen sizes (PDAs, etc.) to large dual monitors can view the presentation easily.  
Streaming technology is also utilized, resulting in viewers being able to see the Flash video quicker (the 
entire file does not have to be downloaded first to begin playback.) 
 
Flash files can contain simple user interaction controls that allow for stopping, rewinding, etc. of the 
presentation.  If you missed the concept the first time, no worries; simply stop and rewind the movie to the 
appropriate section and play again.  Flash movies can also be distributed on CD-ROMs, DVDs and over 
email in addition to the web, making them very versatile. 
 
It was time to start thinking about methodologies used to convert PowerPoint files into Flash movies. 

 
 
Versions of PowerPoint and Flash Utilized in This Report 
 

Before I outline the project, I need to talk about versions of PowerPoint and Flash used in this report. 
 
For Microsoft PowerPoint, I used PowerPoint 2004 (Version 11.1.1) which is the Macintosh-equivalent 
version of the PowerPoint 2003 for Windows. 
 
For Macromedia Flash, I used Flash MX 2004 Professional (Version 7.2) exclusively.  Flash MX 2004 
Professional is cross-platform, and an equivalent version is available for the Windows platform.  Flash 8, the 
next version of Macromedia Flash, will be available in about a month at the time of this writing, so any 
references to the current version of Flash might change when version 8 is released. 
 
On occasion I used FutureCandy's Gordon 1.5, a Macintosh-only Flash decompiler, to view the results of the 
PowerPoint to Flash conversions.  Many Windows-only Flash decompilers can be found on the web (such as 
http://www.19.5degs.com/category/26.php). 
 

 
A Note on Flash Movie File Types 
 

When a movie is saved in Macromedia Flash, the author can specify two different file formats. 
 
The first format, sometimes called the "Flash file format" and given the extension .fla, can be edited and 
changed by anyone who has a copy of Macromedia Flash. 
 
The second format, sometimes called the "Shockwave format" and given the extension .swf, cannot be edited 
or changed (at least not easily - see below.)  Shockwave files can be viewed by anyone with a Shockwave 
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plug-in or program, but the details of the file's construction are not observable to the viewer. 
 
.fla files can be saved as .swf files once the program is ready for viewing by the public.  Usually Flash 
movies on the internet are saved as .swf to keep people viewing the details of the file, etc.  They run fine, but 
you cannot peer inside to see how they are made. 
 
Most of the programs and techniques outlined in Section III export a Flash movie as .swf, meaning that the 
file cannot be altered at a later date unless you have the original PowerPoint file (followed by re-conversion 
to .swf, etc.)  In Section II, the initial file format in Flash will be .fla (we are editing a file from scratch), and 
subsequent preparation for the web will involve conversion to .swf files. 
 
If you have a .swf file that you'd like to see inside of (for details on its construction, etc.) you 
may need the use of a Flash decompiler.  A Flash decompiler can open up .swf files and 
save them as .fla editable in Flash files.  Decompilers are not Macromedia-supported 
programs, and decompiling success will vary depending on the program used.  I utilized a 
Flash decompiler called Gordon to see how some .swf files were put together with a moderate 
amount of success. 
 
It should also be noted that there are programs called Flash Obfuscators that attempt to prevent decompilers 
from accessing their contents.  References and websites for both Decompilers and Obfuscators can be found 
in Section VI at the end of this paper. 
 
 

An Overview of this Report 
 

The "PowerPoint to Flash Conversion Techniques" TLC Innovation Grant Report will provide a brief 
overview of different methods used to convert PowerPoint presentations into Flash movies.  A sample 
PowerPoint file has been created (see: http://gst-d21.com/TLC/PP2FCT/TLC7PPTExample.ppt) and 
converted to Flash movies using both "manual" and "commercial" techniques.   
 
The "manual" techniques require the user to have access to Microsoft PowerPoint and Macromedia Flash; 
also, a certain level of comfort in using Flash must be present in the user.  The manual techniques are cross-
platform (i.e. suitable for both Windows and Macintosh) and detailed instructions on these processes will be 
found in Section II. 
 
The "commercial" techniques outlined in Section III will rely on software obtained from other developers.  
Some of the "commercial" techniques will be quite expensive; others will require a nominal fee and some are 
even free of charge. 
 
Examples of the work created for this report, as well as additional tips and tricks, are available on the web at 
this address:  http://www.gst-d2L.com/TLC 
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II.  Converting PowerPoint Presentations to Flash Movies Manually 
 
 
If you have access to both Microsoft PowerPoint and Macromedia Flash on your computer, and if you like to 
"fine tune" your projects for ultimate creative control, then you will probably wish to convert your 
PowerPoint presentations into Flash movies manually, and this section is for you.  If you would rather have a 
"one click" software option for converting PowerPoint files into Flash movies, then Section III, "Converting 
PowerPoint Presentations into Flash Movies With Commercial Software" will be more to your liking. 
 
Macintosh users will be particularly interested in this section of this report.  As we shall see in Section III, 
almost all of the commercial options available today are geared towards Windows users, and only a handful 
of options exist for converting PowerPoint files to Flash movies on the Macintosh platform.  This is 
unfortunate, but it is hardly a detriment: both PowerPoint and Flash exist in comparable versions on the 
Macintosh platform, so the same results can be obtained through the commercial versions as long as you are 
comfortable tweaking both PowerPoint and Flash files. 
 
Many people are familiar with PowerPoint, but familiarity with Flash is less common.  In this report I will 
try to give relatively detailed instructions on how to use Flash even for beginners.  I recommend the books 
referenced at the end of this report to further your knowledge of Flash, or take the courses listed in Section I 
at Mt. Hood Community College to learn the intricacies of this powerful program. 
 
A comment on Flash: at the time of this writing, Macromedia Flash MX 2004 Professional Edition is the 
current version, but Macromedia Flash 8 (a newer version) is expected within a month, so small 
discrepancies might arise between my printed instructions here and your version of Flash.  Also, I am using 
the Macintosh version of Flash (and PowerPoint), so slight accommodations for Windows users will be 
necessary due to differences in keyboard layout and file management.  If you have any questions, please 
contact me. 
 
First, a couple of caveats about converting PowerPoint presentations into Flash movies: 
 

• PowerPoint bullets may or may not convert correctly into Flash.  The simpler the bullet used in 
PowerPoint, the higher the probability of it converting to Flash correctly. 

 
• If you use text frames or graphical objects not within the slide area in PowerPoint, they will probably 

not be converted correctly to Flash.  The "off slide" elements may be omitted or, maybe, positioned 
inappropriately. 

 
• All fonts used in the PowerPoint presentation to be converted must be on the computer prior to the 

transformation into Flash.  If the font is missing, a substitution will occur which may not be as 
aesthetically pleasing. 

 
• If a graphic used in a PowerPoint presentation is not converting correctly to Flash, it may help to re-

size the graphic in Adobe Photoshop.  Large graphics which are re-sized in PowerPoint to fit a slide 
may or may not convert to Flash correctly. 

 
If you can convert your PowerPoint presentation to meet these criteria before conversion to Flash, your 
conversion quality should be much better. 
 
I found two primary methods to convert PowerPoint presentations into Flash movies that I shall outline 
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separately. 
 
 

Manual PowerPoint to Flash Conversion Technique #1 
 
This method is the simplest manual process for converting PowerPoint presentations into Flash movies.  
Essentially your PowerPoint presentation slides are converted into a series of high resolution raster graphic 
files, then imported into Flash using the "Photo Slideshow" template.  The result is a series of pictures on a 
keyframe in Flash's timeline that can be exported to the .swf format for utilization on the web.  The Flash 
files are quite nice with small file sizes, although some transitions and multimedia are lost. 
 
Converting a PowerPoint Presentation to a Flash Movie manually: 
 

• Open your PowerPoint Presentation in Microsoft PowerPoint.   
 
• Save your PowerPoint presentation as a series of JPEG files (File -> Save As -> JPEG) in a folder of 

your choosing, then press OK.  Each slide of your presentation will be saved as a JPEG graphic file 
with sequential names (Slide1.jpg, Slide2.jpg, etc.)   

 
• Quit PowerPoint.  
 
• Open Macromedia Flash. 
 
• Select File -> New -> Template (tab) ->  Photo Slideshow -> Modern Photo Slideshow, then 

press OK.  You should now have a Flash template open. 
 
• In the upper left corner you should see the Flash Timeline. Each horizontal line is called a layer in 

Flash, and a layer can be deleted by ctrl-clicking the layer and selecting Delete Layer from the 
popup menu.  Delete the "Old Photos" layer as well as the "instructions" layer (if present). 

 
• In the "picture layer" timeline you should see three or so black dots in three or so separate frames.  

Highlight the three black dots with your mouse and then select Edit -> Timeline -> Clear Frames.  
The black dots should disappear, and a clear dot should appear in Frame 1 (which is closest to the 
timeline layer list.) 

 
• Select the empty circle in Frame 1 of the "picture" layer timeline.  Select File -> Import -> Import 

to Stage, then select the first slide in your PowerPoint JPEG file sequence and press OK.  Flash will 
ask if you would like to add the slides in a sequence; click on "Yes".  When it is complete, you 
should see several frames of the "picture" layer filled in with black dots (called keyframes), and 
each dot represents one of your imported PNG files. 

 
• Note the last frame filled in on the "picture" layer.  Click on the frame immediately above this frame 

(which should be on the "transparent frame" layer) and select Insert -> Timeline -> Frame.  Repeat 
this process for the other layers above it ("_overlay", "_controller", "_Captions" and "Title,Date") 

 
• We will now save the presentation as a file capable of viewing on the internet.  Select File -> Save to 

save your Flash file (as a .fla file) with a name provided by you, then press Save.  Then select File -> 
Publish and your .swf file will be created with the same name as your .fla Flash file but with a 
different extension (.swf). 
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• As stated earlier, your .fla file is a file just for editing in Flash later; you probably should not post this 

file on the web.  Instead, post your .swf file to the web (or send via email, etc.)  Congratulations!  
You just created a Flash movie from your PowerPoint presentation! 

 
Additionally, you can change the titles at the beginning and end of the Flash presentation by manipulating 
the "Captions" layer and your "Title,Date" layer.  Select the frame to edit in the relevant layer and type a new 
message. 
 
Files associated with Technique #1 can be found here: 
 

The original PowerPoint file used in this example:       
 http://gst-d21.com/TLC/PP2FCT/TLC7PPTExample.ppt (1.40 MB) 
 
The editable Flash file (.fla) created in this example:        
 http://gst-d2L.com/TLC/PP2FCT/TLCManEx1/TLC7ManEx1.fla (680 KB) 
 
The non-editable shockwave file (.swf) created here for use on the Internet:    
   http://gst-d2L.com/TLC/PP2FCT/TLCManEx1/TLC7ManEx1.swf (356 KB) 
 
The HTML page generated by Flash which incorporates a Flash detection algorithm:   
 http://gst-d2L.com/TLC/PP2FCT/TLCManEx1/TLC7ManEx1.html 

 
There are advantages and disadvantages of this process.  The advantages are that the process is relatively 
easy to undertake, and the resulting file size is small (356 KB versus the 1.40 MB PowerPoint file.)  You can 
alter the Publish settings by selecting File -> Publish Settings... to include a Flash plug-in detection script 
(to ensure that the viewer has the Flash plug-in installed on their computer) and much more. 
 
The disadvantages are great: transitions are not converted with this process, and multimedia must be added in 
separately at a later time using the appropriate keyframe.  (In a nutshell, you will have to Import the 
multimedia into the Library, then select the frame on the layer where you wish the multimedia and insert it.)  
I also find this procedure somewhat aesthetically displeasing, but it is very functional.  However, this process 
will work on any computer system without knowing more about Flash. 
 
Special note to Windows users: instead of JPEG files, you may have better luck importing .wmf (Windows 
metafiles, a special vector graphic files format rarely used in Microsoft Office programs) files from 
PowerPoint.  Select Windows metafiles from the Save As menu in PowerPoint instead of JPEG to try this 
option.  If your version of PowerPoint includes PNG (portable network graphics) output, you might try this 
option also. 
 
Special notes to Macintosh users: instead of JPEG files, you might try using PICT (Macintosh Picture files) 
files instead of JPEG.  As with the Windows' users .wmf files, above, select PICT instead of JPEG and 
follow the remaining instructions accordingly.  If your version of PowerPoint includes PNG (portable 
network graphics) output, you might try this option also. 
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Manual PowerPoint to Flash Conversion Technique #2 (the Template method) 
 
The previous method technique assumes a fairly thorough knowledge of Flash that can be perplexing to the 
novice.  Flash professionals understood this dilemma, so they have created a Flash template that makes the 
process somewhat easier to fathom. 
 
To explore this technique, please download the PowerPoint to Flash template, found here: 
 

http://gst-d21.com/TLC/PP2FCT/ppt_fla.fla (500 KB) 
 

Here are the steps to use with this technique: 
 

• Open your PowerPoint Presentation in Microsoft PowerPoint.   
 
• Save your PowerPoint presentation as a series of PNG (Portable Network Graphics) files (File -> 

Save As -> PNG) in a folder of your choosing, then press OK.  Each slide of your presentation will 
be saved as a PNG graphic file with sequential names (Slide1.png, Slide2.png, etc.)   

 
• Quit PowerPoint.  
 
• Open Macromedia Flash. 
 
• Select File -> Open, navigate to the template (ppt_fla.fla, download link listed above) then press 

OK.  The template opens up.  Select File -> Save As... and save the file under a new name to 
maintain your template.  Your converted Flash movie will have the same name as your Flash file 
name, so choose appropriately (no unusual characters, spaces, etc.) 

 
• In the upper left corner you should see the Flash Timeline. Each horizontal line is called a layer in 

Flash.  Each layer in the timeline can hold a series of "rectangular boxes" called frames that hold the 
content of the Flash movie. 

 
• In the Timeline, click on the first frame of the Slides layer.  Select File -> Import -> Import to 

Stage, then select the first slide in your PowerPoint PNG file sequence and press OK.  Flash will ask 
if you would like to add the slides in a sequence; click on "Yes".  When it is complete, you should see 
several frames of the Slides layer filled in with black dots (called keyframes), and each dot 
represents one of your imported PNG files. 

 
• Note the last frame filled in on the Slides layer.  Click on the frame immediately above this frame 

(which should be on the Slide Num layer) and select Insert -> Timeline -> Frame. 
 
• Note the last frame filled in on the Slide Num layer.  Click on the frame immediately above this 

frame (which should be on the Hot Area layer) and select Insert -> Timeline -> Frame. 
 
• Note the last frame filled in on the Hot Area layer.  Click on the frame immediately above this frame 

(which should be on the Buttons layer) and select Insert -> Timeline -> Frame.  Save your 
presentation (File -> Save). 

 
• We will now save the presentation as a file (or set of files) capable of viewing on the internet.  Select 
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File -> Publish Preview -> HTML to preview your presentation.  If it looks ok, select File -> 
Publish to save your Flash file as an internet viewable .swf file.  Congratulations!  You completed 
the process! 

 
Alternatively, you can change the color of the buttons and slide numbers to be visible against your 
background by unlocking the buttons and/or Slide Num layers, selecting all of the buttons, and changing the 
color using Window -> Design Panels -> Color Swatches. 
 
Files associated with Technique #2 can be found here: 
 

The original PowerPoint file used in this example:        
 http://gst-d21.com/TLC/PP2FCT/TLC7PPTExample.ppt (1.40 MB) 
 
The editable Flash file (.fla) created in this example:       
 http://gst-d2L.com/TLC/PP2FCT/TLC7ManEx2/TLCManEx2.fla (1.96 MB) 
 
The non-editable shockwave file (.swf) created here for use on the Internet:    
 http://gst-d2L.com/TLC/PP2FCT/TLC7ManEx2/TLCManEx2.swf (379 KB) 
 
The HTML page generated by Flash which incorporates a Flash detection algorithm:   
 http://gst-d2L.com/TLC/PP2FCT/TLC7ManEx2/TLCManEx2.html 

 
 
There are advantages and disadvantages of manual conversion process #2.  The advantages are that the 
process is easier to accomplish than conversion process #1, and the resulting file size is still small (379 KB 
versus the 1.40 MB PowerPoint file.)  In addition, I find the resulting product much more aesthetically 
pleasing than the .swf file created in conversion process #1. 
 
The disadvantages are similar to those outlined in process #1: transitions are not converted, and multimedia 
must be added in separately at a later time using the appropriate keyframe.  However, as before this process 
will work on any computer system without knowing more about Flash. 
 
Special note to Windows users: instead of PNG files, you may have better luck importing .wmf (Windows 
metafiles, a special vector graphic files format rarely used in Microsoft Office programs) files from 
PowerPoint.  Select Windows metafiles from the Save As menu in PowerPoint instead of PNG to try this 
option.  
 
Special notes to Macintosh users: instead of JPEG files, you might try using PICT (Macintosh Picture files) 
files instead of PNG.  As with the Windows' users .wmf files, above, select PICT instead of PNG and follow 
the remaining instructions accordingly. 
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III.  Converting PowerPoint Presentations to Flash Movies With Commercial Software 
 

 
If converting PowerPoint presentations into Flash movies using the manual methods in Section II do not 
appeal to you or if you do not own a copy of Macromedia Flash, then the programs outlined in this section 
should pique your curiosity. 
 
Macromedia Flash can be a difficult program to learn, and the learning curve can be quite steep.  Fortunately 
a number of savvy computer programmers have realized this fact, and they have created software specifically 
for the conversion of PowerPoint presentations into Flash movies. 
 
Some of the programs listed in this section act as Microsoft PowerPoint plug-ins, allowing for a conversion 
to Flash using only one or two clicks of the mouse from within the PowerPoint program.  Other programs in 
this section require you to save the PowerPoint file, and then import it into their program before being 
exported to a Flash movie. 
 
The cost of these commercial programs runs the gamut of prices.  Some are free, while others require 
hundreds of dollars to acquire.  Most if not all of the program have a "trial version" for evaluating if the 
software is right for you and your presentations.  I definitely recommend trying the software before buying 
any, especially since there are so many titles to choose from. 
 
Almost all of the programs listed below work well on Windows XP or greater (except Keynote and 
NeoOffice.)  Almost none of the programs work natively on the Macintosh platform (except Keynote, 
NeoOffice, OpenOffice and Impatica.)  Macintosh users are definitely at a disadvantage when converting 
their PowerPoint files into Flash movies, and I cannot help but think that a great market exists for 
programmers willing to port code from a Windows-based PowerPoint to Flash converter into a Macintosh 
OS X version... but do not despair, Mac-users: the manual methods listed in Section II still apply to you as 
well as the Windows people. 
 
On the Windows platform, if money is no object, I would strongly recommend considering PowerConverter 
($495) and Presenter ($499 - $699).  I found nothing but glowing reviews for both programs in my searches, 
and I think I would start my investigations there. 
 
On the Windows platform, if money is of concern, I would strongly recommend considering iMediaConvert 
($95), OpenOffice (free) and PPT2SWF (either version, free or about $26).  For under $100, iMediaConvert 
received excellent marks on several of the websites I looked through, making it a low cost alternative to the 
more expensive PowerConverter and Presenter.  OpenOffice requires a JAVA Runtime Environment (which 
is also free and can be set up on almost any computer) but it does the job quite adequately.  Several people 
reported good results using PPT2SWF. 
 
On the Apple platform, Keynote 2 is the hands-down favorite for converting PowerPoint presentations into 
Flash movies, although some users reported trouble in their conversions.  The above-mentioned NeoOffice 
also runs well on the Macintosh with a Java Runtime Environment.  Impatica is an intriguing option.  
 
I have cataloged the various PowerPoint to Flash converters available commercially through the internet 
below.  A reference website is provided along with some notes on each program (including the platforms 
supported).  The price as of September 2005 is given, but these are obviously subject to change at any time. 
 
 



 

"PowerPoint to Flash Conversion Techniques" TLC Innovation Grant Page 13 by Michael Russell 

 
 

PowerPoint to Flash Conversion Programs 
 
AuthorGEN 

• http://authorgen.com/ - AuthorGEN by Sikhya Solutions LLC, Windows only, $249 for the Flash 
option (AuthorGEN Plus). 

• AuthorGEN is designed to capture audio and video with PowerPoint presentations while they are 
being delivered; you could essentially "record" your class PowerPoint lectures using the AuthorGEN 
system.  AuthorGEN Plus for PowerPoint allows the user to output the final file to a Flash file.  A 
trial version is available. 

 
Breeze 

• http://www.macromedia.com/software/breeze/ - Breeze (formerly Presedia Producer) by 
Macromedia, Windows only (for PowerPoint conversions), price varies but a trial version is 
available.   

• A great web conferencing and live presentation tool, but the price is quite steep and a Breeze server is 
required for full functionality. 

 
Captivate 

• http://www.macromedia.com/software/captivate/ - Captivate (formerly eHelp RoboDemo) by 
Macromedia, Windows only, $499.   

• Captivate provides an easy method to create software simulations and demonstrations in the Flash 
format, and output can be saved in a variety of types (SWF, FLA, EXE, etc.)  Captivate includes a 
full featured PowerPoint converter which receives mixed reviews on the Web due to quality and file 
size concerns.  A trial version is available. 

 
Director 

• http://www.macromedia.com/software/director/ - Director by Macromedia, Windows only (for 
PowerPoint conversions, Macintosh version does not convert PowerPoint files), $1200.   

• Director is a powerful multimedia content generator, and the Windows version of Director includes a 
conversion utility for transforming PowerPoint files into Flash movies.  The Macintosh version does 
not convert PowerPoint files into Flash movies.  There are some rumblings on the internet that 
suggest a limited timeline for continuing the PowerPoint to Flash converting feature within Director.  
A trial version is available. 

 
Direct-to-Web 

• http://www.knowledgedirectweb.com/2090.htm - Direct-to-Web by Knowledge Direct, Windows 
only, $495. 

• Direct-to-Web facilitates the creation of learning objects which can include presentations, games, 
movies, and more.  This program has a PowerPoint add-in which converts the presentation to the 
Flash format, and the Flash movie can be accessed over the Web or burned to a CD or DVD.  A free 
evaluation copy is available. 

 
EyeCron 

• http://www.eyecron.com/ - EyeCron by EyeCron, Windows only, price not available. 
• EyeCron is a professional service that converts your PowerPoint files into Flash animations.  

EyeCron offers to record narration for a Flash presentation over the telephone then add it to the 
presentation.  EyeCron also provides a complex, feature-rich enterprise solution for businesses.  A 
trial subscription is available. 
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FlashPaper 2 

• http://www.macromedia.com/software/flashpaper/ - FlashPaper 2 by Macromedia, Windows and 
Macintosh, $79.   

• FlashPaper is a utility to convert printable documents into Flash or PDF files.  FlashPaper had been 
seen as Macromedia's challenger to Adobe Acrobat, but now that Macromedia has been acquired by 
Adobe, the future of FlashPaper is uncertain.  FlashPaper can convert PowerPoint files into Flash 
pages, but the output comes out as one Flash file per PowerPoint slide, making this an inconvenient 
tool for converting entire PowerPoint presentations into Web accessible files.  A trial version is 
available. 

 
FlashPoint 

• http://www.justdosoft.com/powerpoint-to-flash/ - FlashPoint by JustDo Software, Windows only, 
$98. 

• FlashPoint is a PowerPoint plug-in which facilitates the conversion of PowerPoint files into Flash 
presentations.  FlashPoint can be installed on a central server for bulk conversion of PowerPoint files.  
FlashPoint is the PowerPoint to Flash conversion engine in the Avacaster suite 
(http://www.avacast.com/).  A trial version is available. 

 
FlashPPT 

• http://www.ypgsoft.com/flashppt.htm - FlashPPT by Ypgsoft, Windows only, $49.95. 
• FlashPPT is a PowerPoint to Flash converter compatible with PowerPoint 2000 or above.  Out of all 

the products listed here, I would be most cautious to invest in FlashPPT; the website had typing 
errors, poor grammar, and I would be cautious about this program.  A trial version is available. 

 
FlashSpring 

• http://www.activeswf.com/ - FlashSpring by ActiveSWF, Windows only, $149. 
• FlashSpring converts PowerPoint files into Flash movies with a couple of mouse clicks.  FlashSpring 

is especially efficient with PowerPoint animations.  A trial version is available. 
 
iMediaConvert 

• http://www.imedialearn.com/imediaconvert/ - iMediaConvert (formerly Netron) by iMediasoft, 
Windows only, $95.   

• An affordable, functional PowerPoint to Flash converter, iMediaConvert turns PowerPoint 
presentations into small sized Flash movies directly from within PowerPoint.  iMediaConvert also 
offers some control over what material may be copied from the Flash presentation.  Updates are free, 
and a free trial version is available. 

 
Keynote 2 

• http://www.apple.com/iwork/keynote/ - Keynote 2 by Apple, Macintosh only, $79.   
• Keynote 2 is one of the best PowerPoint to Flash converters for the Macintosh platform.  PowerPoint 

files can be imported into Keynote, then exported as Flash movies.  The Macintosh community is 
expectantly waiting for Keynote 3 (release date uncertain) because of its rumored higher quality 
Flash converting capabilities. 

 
continued
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NeoOffice 
• http://www.neooffice.org/ - NeoOffice by NeoWiki, Macintosh only, free (open source).   
• This open source suite of programs requires a Java Runtime Environment (JRE) to be present on your 

computer, but I found the setup to be relatively painless.  NeoOffice uses the same code as 
OpenOffice except that all code is geared directly to the Macintosh OS X platform.  Conversion of 
PowerPoint files into Flash .swf movies works well. 

 
OpenOffice 

• http://www.openoffice.org/ - OpenOffice by OpenOffice.org, Macintosh/Windows/UNIX platforms, 
free (open source).   

• This open source suite of programs requires a Java Runtime Environment (JRE) to be present on your 
computer, but I found the setup to be relatively painless.  The Impress program within OpenOffice is 
equivalent to PowerPoint, and PowerPoint files can be imported into Impress and then exported as 
Flash movies.  Transitions and animations are not supported, but updates to OpenOffice occur quite 
regularly. 

 
Powerbullet Presenter 

• http://powerbullet.com/ - Powerbullet Presenter by DDD Pty, Windows only, free or $19.95 (pro 
version).   

• Powerbullet Presenter is a low-cost conversion utility for creating Flash movies from PowerPoint 
presentations.  It is relatively easy to use, and the conversions are accomplished with high quality.  A 
"regular" version is free, and a "pro" version is $19.95 that comes with technical support, additional 
features, etc. 

 
PowerConverter 

• http://www.presentationpro.com/products/powerconverter.asp - PowerConverter by 
PresentationPro, Windows only, $149 - $399 depending on the version.   

• PowerConverter is a PowerPoint plug-in that converts your presentations to Flash movies quickly.  
PowerConverter is seen as one of the best PowerPoint to Flash converters available on the market.  
The PowerConverter engine is used to convert PowerPoint files into Flash movies within the Convoq 
suite (http://www.convoq.com/). 

 
PowerPoint to Flash 

• http://www.dreamingsoft.com/powerpointtoflash/index.htm - PowerPoint to Flash by Dreamingsoft, 
Windows only, $49.95.   

• An easy to use PowerPoint to Flash converter used in the ReadyGo web based training with web 
course builder suite (http://www.readygo.com/).  A trial version of PowerPoint to Flash is available. 

 
PPT2SWF (first version) 

• http://www.softacademia.com/products/products_pp2swf.htm - PPT2SWF by SoftAcademia LLC, 
Windows only, $26. 

• A relatively cheap PowerPoint to Flash converter, PPT2SWF recognizes ActiveX objects and 
transforms recognizable PowerPoint objects readily (although it deletes objects it does not recognize.)  
A trial version is available. 
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PPT2SWF (second version) 

• http://www.ajsoftpk.com/ppt2swf.html - PPT2SWF by AJSoft, Windows only, free. 
• A free tool that converts PowerPoint slides into Flash movies.  Animations are handled well.  

 
Presenter 

• http://www.articulate.com/presenter.html - Presenter by Articulate, Windows only, $499 - $699.   
• Touted as the Flash converter for people with little or no experience with Flash, Presenter can convert 

PowerPoint presentations to Flash movies with a click of the mouse.  More expensive than other 
options listed here, but also reportedly high quality.  A free trial is available. 

 
Publisher 

• http://www.pointecast.com/products/publisher-overview.html - Publisher by Pointecast, Windows 
only, $99 - $499. 

• Seen as a cost-effective alternative to Macromedia's Breeze, Publisher turns PowerPoint presentations 
into Flash presentations that can be interactive and of high quality.  Different versions of Publisher 
are for sale, some of which allow for background audio, viewing PowerPoint notes, time tracking, 
and related tools.  A demo version is available. 

 
QuickFlash 

• http://www.webspiders.com/en/nalanda_quick_flash.asp - QuickFlash by Web Spiders, Windows 
only, $99.95. 

• QuickFlash instantly converts PowerPoint slides into Flash movies.  QuickFlash claims to convert a 
variety of multimedia content seamlessly, and it also touts the capability of turning each individual 
PowerPoint slide into a separate Flash movie.  A demo version is available. 

 
SameShow 

• http://www.sameshow.com/ - SameShow by Wondershare Software, Windows only, $79.95 - 
$149.95. 

• SameShow converts PowerPoint presentations into Flash movies seamlessly, preserving audio, 
animations, and other PowerPoint features not preserved by other programs.  SameShow reduces the 
file size significantly to easier distribution over the Web.  Narration can be recorded for the 
presentation and synchronized with the Flash movie.  A demo version is available. 

 
Speechi 

• http://www.speechi.net/speechi/site%5Fus/ - Speechi by Wouarf SARL, Windows only, $690. 
• Speechi is a PowerPoint to Flash converter aimed at educators.  Presentations can be augmented with 

microphone narrated speech and saved in the Flash movie; in addition, online "hand writing" 
annotations (similar to a White board) can be added easily to your movie.  A demo version is 
available. 
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Other PowerPoint Converters of Interest: (all sites accessed September 2005; all prices 
subject to change) 
 
Impatica 

• http://www.impatica.com/imp4ppt/ - Impatica by Impatica, Windows and Macintosh, price 
unavailable. 

• Impatica converts PowerPoint presentations into Java applets viewable by almost any browser.  The 
final output looks and feels like a Flash presentation, but a Flash / Shockwave plug-in is not required 
to run an Impatica presentation.  File formats are generally smaller, and conversion quality is high.  A 
demo version is available. 

 
PowerPoint to EXE 

• http://www.angelfire.com/va3/powerpoint_to_exe/ - PowerPoint to EXE, Windows only, price 
varies by project (see website). 

• PowerPoint to EXE converts PowerPoint presentations into Windows executable files.  No plug-ins 
or PowerPoint program is required to view the presentation (which looks much like a Flash 
presentation), but you must be running a Windows computer to view the presentation.  A demo 
version is available. 

 
 
Examples of PowerPoint Presentations Converted to Flash Movies Using Commercial 
Software 
 
I have used two of the commercial products to convert a sample PowerPoint presentation into a Flash movie.  
You can view them here: 
 

The Original PowerPoint Presentation:        
 http://gst-d2L.com/TLC/PP2FCT/TLC7PPTExample.ppt (1.40 MB) 
 
PowerPoint to Flash Conversion Using Keynote 2:      
 http://gst-d2L.com/TLC/PP2FCT/TLC7KeyNote2Flash.swf (1.41 MB) 
 
PowerPoint to Flash Conversion Using OpenOffice:      
 http://gst-d2L.com/TLC/PP2FCT/TLC7OpenOffice2Flash.swf (222 KB) 
 

Converting the PowerPoint presentation into a Flash movie was much nicer using Keynote 2 and OpenOffice 
than it was using the "manual" methods in Section II, and the results with Keynote 2 are of much higher 
quality.  Both programs converted the presentation effortlessly, but Keynote 2 accomplished the task with 
higher quality.  OpenOffice did not convert some of the graphic colors correctly, nor was the multimedia 
element included in the text; in addition, unexpectedly one of the fonts did not translate into the final .swf 
Flash movie.   
 
Between these two programs, Keynote 2 does a much nicer job than OpenOffice.  However, OpenOffice is a 
free program while Keynote costs just under $100; in addition, the file size of the OpenOffice .swf file was 
much smaller than the Keynote converted .swf file.   
 
If nothing else, one should try many different commercial PowerPoint to Flash conversion programs before 
purchasing any software! 
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IV.  Final Thoughts 
 
 
In the age of the internet, the speed of life shows little signs of slowing down anytime soon.  Deadlines come 
quicker due to easier information acquisition strategies, and life is thrust upon us at an increasing velocity.  
Ah!  To be a teacher at the turn of the twentieth century!   
 
As instructors we must realize these velocity shifts within our students' lives as well as our own.  Many of 
my students work forty hours each week and attempt to keep some sort of family structure in addition to their 
classes at Mt. Hood Community College.  The line between chaos and order narrows almost to the point of 
oblivion, but miraculously order still reigns in the majority of cases. 
 
Having a structured three hours per week lecture system is still the ideal method for delivering academic 
content to students in my opinion; however, for some people in some situations, this medium may not apply 
anymore.  This is why it is up to us as instructors to find new learning paradigms so these struggling 
members of the student body remain competitive and current with their peers at other institutions. 
 
The goal of the perfect online lecture is probably a dream, but I believe that we can aspire to a learning 
methodology that incorporates as many of the desired "face to face" lecture elements as possible.  As you can 
see from this report, I have experimented with many such methods, some of them being more successful than 
others, and I believe that the best of the methodologies incorporates Flash to deliver lecture content. 
 
Is Flash a perfect medium for delivering lecture content to online learners?  No.  A real face-to-face lecture 
has student-student and student-teacher interactions, and Flash movies have yet to conquer this realm.  But 
through discussion boards, live iChat-like video conferencing office hours and related technologies, maybe 
we can get closer to the desired result than we had thought possible initially. 
 
Good luck with your PowerPoint to Flash conversions!  I look forward to hearing of your creative endeavors, 
and please let me know if I can help you to attain your teaching goals.  To the future! 
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VI.  Resources For Additional Information 
 
 
Printed Material on Microsoft PowerPoint: 
 

• Schwartz, Steve "Microsoft Office 2004 for Mac OS X: Visual QuickStart Guide," Peachpit Press 
(Berkeley, CA), 2004. 

• Altman, Rebecca and Altman, Rick "Microsoft Office 2003 for Windows (Visual QuickStart 
Guide)," Peachpit Press (Berkeley, CA), 2003. 

 
Printed Material on Macromedia Flash: 
 

• Ulrich, Katherine "Macromedia Flash MX 2004 for Windows and Macintosh: Visual QuickStart 
Guide," Peachpit Press (Berkeley, CA), 2003. 

• Chun, Russell and Garraffo, Joe "Macromedia Flash MX 2004 Advanced for Windows and 
Macintosh: Visual QuickStart Guide," Peachpit Press (Berkeley, CA), 2003. 

• Watrall, Ethan and Herber, Norbert "Flash MX 2004 Savvy", Sybex (Alameda, CA), 2004. 
 
PowerPoint to Flash Conversion Techniques Web Addresses: (all sites accessed September 
2005) 

 
• http://web-1.sgc.peachnet.edu/~rreiman/page/howtodo.htm - "How to convert a PowerPoint slide 

show into a Macromedia Flash file" 
• http://dmc.umn.edu/objects/ppt_fla/ppt_fla.shtml - "U of M Digital Media Center: PowerPoint to 

Flash converter" 
• http://www.tc.umn.edu/~kurtis/flash/ppt_fla/ - "PowerPoint to Flash Learning Object" 
• http://www.flashgeek.com/tutorials/09_ppttofla_01.htm - ".flashgeek... Getting PowerPoint Into 

Flash" 
• http://www.indezine.com/articles/flashppt2.html - "Giving PowerPoint Pizzazz with Macromedia 

Flash" 
 

PowerPoint to Flash Commercial Software Conversion Programs: (all sites accessed 
September 2005; all prices subject to change) 
 
AuthorGEN 

• http://authorgen.com/ - AuthorGEN  by Sikhya Solutions LLC, Windows only, $249 for the Flash 
option (AuthorGEN Plus). 

• AuthorGEN is designed to capture audio and video with PowerPoint presentations while they are 
being delivered; you could essentially "record" your class PowerPoint lectures using the AuthorGEN 
system.  AuthorGEN Plus for PowerPoint allows the user to output the final file to a Flash file.  A 
trial version is available. 

 
Breeze 

• http://www.macromedia.com/software/breeze/ - Breeze (formerly Presedia Producer) by 
Macromedia, Windows only (for PowerPoint conversions), price varies but a trial version is 
available.   

• A great web conferencing and live presentation tool, but the price is quite steep and a Breeze server is 
required for full functionality. 
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Captivate 

• http://www.macromedia.com/software/captivate/ - Captivate (formerly eHelp RoboDemo) by 
Macromedia, Windows only, $499.   

• Captivate provides an easy method to create software simulations and demonstrations in the Flash 
format, and output can be saved in a variety of types (SWF, FLA, EXE, etc.)  Captivate includes a 
full featured PowerPoint converter which receives mixed reviews on the Web due to quality and file 
size concerns.  A trial version is available. 

 
Director 

• http://www.macromedia.com/software/director/ - Director by Macromedia, Windows only (for 
PowerPoint conversions, Macintosh version does not convert PowerPoint files), $1200.   

• Director is a powerful multimedia content generator, and the Windows version of Director includes a 
conversion utility for transforming PowerPoint files into Flash movies.  The Macintosh version does 
not convert PowerPoint files into Flash movies.  There are some rumblings on the internet that 
suggest a limited timeline for continuing the PowerPoint to Flash converting feature within Director.  
A trial version is available. 

 
Direct-to-Web 

• http://www.knowledgedirectweb.com/2090.htm - Direct-to-Web by Knowledge Direct, Windows 
only, $495. 

• Direct-to-Web facilitates the creation of learning objects that can include presentations, games, 
movies, and more.  This program has a PowerPoint add-in that converts the presentation to the Flash 
format, and the Flash movie can be accessed over the Web or burned to a CD or DVD.  A free 
evaluation copy is available. 

 
EyeCron 

• http://www.eyecron.com/ - EyeCron by EyeCron, Windows only, price not available. 
• EyeCron is a professional service that converts your PowerPoint files into Flash animations.  

EyeCron offers to record narration for a Flash presentation over the telephone then add it to the 
presentation.  EyeCron also provides a complex, feature-rich enterprise solution for businesses.  A 
trial subscription is available. 

 
FlashPaper 2 

• http://www.macromedia.com/software/flashpaper/ - FlashPaper 2 by Macromedia, Windows and 
Macintosh, $79.   

• FlashPaper is a utility to convert printable documents into Flash or PDF files.  FlashPaper had been 
seen as Macromedia's challenger to Adobe Acrobat, but now that Macromedia has been acquired by 
Adobe, the future of FlashPaper is uncertain.  FlashPaper can convert PowerPoint files into Flash 
pages, but the output comes out as one Flash file per PowerPoint slide, making this an inconvenient 
tool for converting entire PowerPoint presentations into Web accessible files.  A trial version is 
available. 

 
continued
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FlashPoint 
• http://www.justdosoft.com/powerpoint-to-flash/ - FlashPoint by JustDo Software, Windows only, 

$98. 
• FlashPoint is a PowerPoint plug-in which facilitates the conversion of PowerPoint files into Flash 

presentations.  FlashPoint can be installed on a central server for bulk conversion of PowerPoint files.  
FlashPoint is the PowerPoint to Flash conversion engine in the Avacaster suite 
(http://www.avacast.com/).  A trial version is available. 

 
FlashPPT 

• http://www.ypgsoft.com/flashppt.htm - FlashPPT by Ypgsoft, Windows only, $49.95. 
• FlashPPT is a PowerPoint to Flash converter compatible with PowerPoint 2000 or above.  Out of all 

the products listed here, I would be most cautious to invest in FlashPPT; the website had typing 
errors, poor grammar, and I would be cautious about this program.  A trial version is available. 

 
FlashSpring 

• http://www.activeswf.com/ - FlashSpring by ActiveSWF, Windows only, $149. 
• FlashSpring converts PowerPoint files into Flash movies with a couple of mouse clicks.  FlashSpring 

is especially efficient with PowerPoint animations.  A trial version is available. 
 
iMediaConvert 

• http://www.imedialearn.com/imediaconvert/ - iMediaConvert (formerly Netron) by iMediasoft, 
Windows only, $95.   

• An affordable, functional PowerPoint to Flash converter, iMediaConvert turns PowerPoint 
presentations into small sized Flash movies directly from within PowerPoint.  iMediaConvert also 
offers some control over what material may be copied from the Flash presentation.  Updates are free, 
and a free trial version is available. 

 
Keynote 2 

• http://www.apple.com/iwork/keynote/ - Keynote 2 by Apple, Macintosh only, $79.   
• Keynote 2 is one of the best PowerPoint to Flash converters for the Macintosh platform.  PowerPoint 

files can be imported into Keynote, then exported as Flash movies.  The Macintosh community is 
expectantly waiting for Keynote 3 (release date uncertain) because of its rumored higher quality 
Flash converting capabilities. 

 
NeoOffice 

• http://www.neooffice.org/ - NeoOffice by NeoWiki, Macintosh only, free (open source).   
• This open source suite of programs requires a Java Runtime Environment (JRE) to be present on your 

computer, but I found the setup to be relatively painless.  NeoOffice uses the same code as 
OpenOffice except that all code is geared directly to the Macintosh OS X platform.  Conversion of 
PowerPoint files into Flash .swf movies works well. 

 
continued
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OpenOffice 
• http://www.openoffice.org/ - OpenOffice by OpenOffice.org, Macintosh/Windows/UNIX platforms, 

free (open source).   
• This open source suite of programs requires a Java Runtime Environment (JRE) to be present on your 

computer, but I found the setup to be relatively painless.  The Impress program within OpenOffice is 
equivalent to PowerPoint, and PowerPoint files can be imported into Impress and then exported as 
Flash movies.  Transitions and animations are not supported, but updates to OpenOffice occur quite 
regularly. 

 
Powerbullet Presenter 

• http://powerbullet.com/ - Powerbullet Presenter by DDD Pty, Windows only, free or $19.95 (pro 
version).   

• Powerbullet Presenter is a low-cost conversion utility for creating Flash movies from PowerPoint 
presentations.  It is relatively easy to use, and the conversions are accomplished with high quality.  A 
"regular" version is free, and a "pro" version is $19.95 that comes with technical support, additional 
features, etc. 

 
PowerConverter 

• http://www.presentationpro.com/products/powerconverter.asp - PowerConverter by 
PresentationPro, Windows only, $149 - $399 depending on the version.   

• PowerConverter is a PowerPoint plug-in that converts your presentations to Flash movies quickly.  
PowerConverter is seen as one of the best PowerPoint to Flash converters available on the market.  
The PowerConverter engine is used to convert PowerPoint files into Flash movies within the Convoq 
suite (http://www.convoq.com/). 

 
PowerPoint to Flash 

• http://www.dreamingsoft.com/powerpointtoflash/index.htm - PowerPoint to Flash by Dreamingsoft, 
Windows only, $49.95.   

• An easy to use PowerPoint to Flash converter used in the ReadyGo web based training with web 
course builder suite (http://www.readygo.com/).  A trial version of PowerPoint to Flash is available. 

 
PPT2SWF (first version) 

• http://www.softacademia.com/products/products_pp2swf.htm - PPT2SWF by SoftAcademia LLC, 
Windows only, $26. 

• A relatively cheap PowerPoint to Flash converter, PPT2SWF recognizes ActiveX objects and 
transforms recognizable PowerPoint objects readily (although it deletes objects it does not recognize.)  
A trial version is available. 

 
PPT2SWF (second version) 

• http://www.ajsoftpk.com/ppt2swf.html - PPT2SWF by AJSoft, Windows only, free. 
• A free tool that converts PowerPoint slides into Flash movies.  Animations are handled well.  

 
Presenter 

• http://www.articulate.com/presenter.html - Presenter by Articulate, Windows only, $499 - $699.   
• Touted as the Flash converter for people with little or no experience with Flash, Presenter can convert 

PowerPoint presentations to Flash movies with a click of the mouse.  More expensive than other 
options listed here, but also reportedly high quality.  A free trial is available. 
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Publisher 

• http://www.pointecast.com/products/publisher-overview.html - Publisher by Pointecast, Windows 
only, $99 - $499. 

• Seen as a cost-effective alternative to Macromedia's Breeze, Publisher turns PowerPoint presentations 
into Flash presentations that can be interactive and of high quality.  Different versions of Publisher 
are for sale, some of which allow for background audio, viewing PowerPoint notes, time tracking, 
and related tools.  A demo version is available. 

 
QuickFlash 

• http://www.webspiders.com/en/nalanda_quick_flash.asp - QuickFlash by Web Spiders, Windows 
only, $99.95. 

• QuickFlash instantly converts PowerPoint slides into Flash movies.  QuickFlash claims to convert a 
variety of multimedia content seamlessly, and it also touts the capability of turning each individual 
PowerPoint slide into a separate Flash movie.  A demo version is available. 

 
SameShow 

• http://www.sameshow.com/ - SameShow by Wondershare Software, Windows only, $79.95 - 
$149.95. 

• SameShow converts PowerPoint presentations into Flash movies seamlessly, preserving audio, 
animations, and other PowerPoint features not preserved by other programs.  SameShow reduces the 
file size significantly to easier distribution over the Web.  Narration can be recorded for the 
presentation and synchronized with the Flash movie.  A demo version is available. 

 
Speechi 

• http://www.speechi.net/speechi/site%5Fus/ - Speechi by Wouarf SARL, Windows only, $690. 
• Speechi is a PowerPoint to Flash converter aimed at educators.  Presentations can be augmented with 

microphone narrated speech and saved in the Flash movie; in addition, online "hand writing" 
annotations (similar to a White board) can be added easily to your movie.  A demo version is 
available. 

 
Other PowerPoint Converters of Interest: (all sites accessed September 2005; all prices 
subject to change) 
 
Impatica 

• http://www.impatica.com/imp4ppt/ - Impatica by Impatica, Windows and Macintosh, price 
unavailable. 

• Impatica converts PowerPoint presentations into Java applets viewable by almost any browser.  The 
final output looks and feels like a Flash presentation, but a Flash / Shockwave plug-in is not required 
to run an Impatica presentation.  File formats are generally smaller, and conversion quality is high.  A 
demo version is available. 

 
PowerPoint to EXE 

• http://www.angelfire.com/va3/powerpoint_to_exe/ - PowerPoint to EXE, Windows only, price 
varies by project (see website). 

• PowerPoint to EXE converts PowerPoint presentations into Windows executable files.  No plug-ins 
or PowerPoint program is required to view the presentation (which looks much like a Flash 
presentation), but you must be running a Windows computer to view the presentation.  A demo 
version is available. 
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Miscellaneous PowerPoint and Flash Websites: (all sites accessed September 2005) 
 

• http://www.gst-d2L.com/TLC - Russell, Michael and Shriner, Walter "Maximizing the Power of 
PowerPoint in the Classroom", Teaching and Learning Cooperative Grant (2001) 

• http://www.masternewmedia.org/2004/04/14/powerpoint_to_flash_conversion_tools.htm - 
"PowerPoint to Flash Conversion Tools - the PPT2Flash Top20 - Robin Good's Sharewood Tidings" 

• http://www.futurecandy.com/ - "FutureCandy Flash" - Home of FutureCandy's Gordon Flash 
decompiler (Macintosh only) 

• http://www.19.5degs.com/category/26.php - "SWF Decompilers / SWF Extractors" - a list of popular 
Flash decompilers and media extractors for a variety of computer platforms 

• http://www.bestflashanimationsite.com/resources/decompilers/ - "SWF Decompilers - Obfuscators - 
Best Flash Animation Site.com V2" - a list of helpful Flash decompilers and obfuscators 

• http://www.kolabora.com/news/2005/02/18/how_to_deliver_a_mac.htm - "How to Deliver a Mac 
Presentation to Distant Viewers? Lawrence Lessig Finds Out - Online Collaboration and Web 
Conferencing Breaking News - Kolabora.com" - nice blog outlining presentation options for 
Macintosh and Windows users 

• http://www.tegrity.com/ - "Tegrity - Lead with Learning Technology - Serve More Students with the 
Best-In-Class Learning Experience - Tegrity, Web Learner, Learning Technology, eLearning, 
distance education, streaming powerpoint, streaming video, streaming video production, Tablet PC, 
electronic whiteboard capture" - a Windows-only online lecture delivery system currently in use at 
MHCC 

• http://www.caststream.com/ - "c a s t : s t r e a m" - a wonderful cross-platform online lecture 
delivery system which holds great promise, especially when compared to the Tegrity system 


